Wednesday, September 26, 2007

Routing with Cisco 2500 and 1000 Series for LAN-ISDN Service

Commands
Commands - General

There are 3 different modes of operation within the Cisco IOS.

1. Disabled mode
2. Enabled mode
3. Configuration mode

In the Disabled mode you can use a limited number of commands. This is used primarily to monitor the router.

The Enabled mode is used to show configuration information, enter the configuration mode, and make changes to the configuration.

The Configuration mode is used to enter and update the runtime configuration.

To get a list of the commands for the cisco type '?' at the prompt. To get further information about any command, type the command followed by a '?'.
clear Reset functions
clock Manage the system clock
configure Enter configuration mode
debug Debugging functions (see also 'undebug')
disable Turn off privileged commands
enable Turn on privileged commands
erase Erase flash or configuration memory
exit Exit from the EXEC
help Description of the interactive help system
login Log in as a particular user
logout Exit from the EXEC
no Disable debugging functions
ping Send echo messages
reload Halt and perform a cold restart
setup Run the SETUP command facility
show Show running system information
telnet Open a telnet connection
terminal Set terminal line parameters
test Test subsystems, memory, and interfaces
traceroute Trace route to destination
tunnel Open a tunnel connection
undebug Disable debugging functions (see also 'debug')
verify Verify checksum of a Flash file
write Write running configuration to memory, network, or terminal
show
access-lists List access lists
arp ARP table
buffers Buffer pool statistics
configuration Contents of Non-Volatile memory
controllers Interface controller status
debugging State of each debugging option
dialer Dialer parameters and statistics
extended Extended Interface Information
flash System Flash information
flh-log Flash Load Helper log buffer
history Display the session command history
hosts IP domain-name, lookup style, name servers, and host table
interfaces Interface status and configuration
ip IP information
isdn ISDN information
line TTY line information
logging Show the contents of logging buffers
memory Memory statistics
privilege Show current privilege level
processes Active process statistics
protocols Active network routing protocols
queue Show queue contents
queueing Show queueing configuration
reload Scheduled reload information
route-map route-map information
running-config Current operating configuration
sessions Information about Telnet connections
smf Software MAC filter
stacks Process stack utilization
startup-config Contents of startup configuration
subsys Show subsystem information
tcp Status of TCP connections
terminal Display terminal configuration parameters
users Display information about terminal lines
version System hardware and software status
Other Useful Commands

View the Software Version

Cisco>en
Cisco#wr term <--- Shows the running configuration Building configuration... Current configuration: ! version 11.2 no service udp-small-servers no service tcp-small-servers ! hostname Cisco ! interface Ethernet0 ip address 192.168.1.1 255.255.255.0 ! interface Serial0 ip address 192.168.6.1 255.255.255.0 encapsulation frame-relay frame-relay lmi-type ansi ! interface Serial1 ip address 192.168.4.2 255.255.255.0 encapsulation frame-relay bandwidth 1536 keepalive 5 frame-relay map ip 192.168.4.1 101 IETF ! router rip version 2 network 192.168.4.0 network 192.168.6.0 neighbor 192.168.6.2 neighbor 192.168.4.1 ! ip classless ip route 0.0.0.0 0.0.0.0 192.168.6.2 ip route 0.0.0.0 0.0.0.0 192.168.4.1 ! line con 0 line aux 0 line vty 0 4 login ! end View the Ethernet IP

From the enable command prompt:



Router#wr term



This will show the running configuration.
Within the configuration, you will see an interface ethernet 0 section:



interface Ethernet0
ip address 38.150.93.1 255.255.255.0
no ip directed-broadcast

View the Serial IP

From the enable command prompt:



Router#wr term



Within the configuration, you will see an interface serial 0 section:



interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

View the Default Route

From the enable command prompt:



Router#wr term



Within the configuration, you will see an ip route section.



In the ip route section, look for a route:
ip route 0.0.0.0 0.0.0.0 38.167.29.1
The last ip address is the POP ip.

View the Filters

From the enable command prompt:



Router#wr term



Under interface serial 0, look for:



ip access-group 104 in
ip access-group 105 out



This means that access-group 104 is the inbound filter set and
access-group 105 is the outbound filter set.
Then, continue to look in the configuration for the access-list statements:



(Example access-list statements)
access-list 104 deny ip 38.166.101.0 0.0.0.255 any
access-list 104 permit tcp any any established
access-list 104 permit tcp any eq ftp-data any gt 1023
access-list 104 permit udp any eq domain any gt 1023
access-list 104 permit udp any eq domain any eq domain
access-list 104 permit icmp any any
access-list 104 permit udp any eq snmp any gt 1023
access-list 105 deny ip any 38.166.101.0 0.0.0.255
access-list 105 permit tcp any any established
access-list 105 permit tcp any any eq ftp
access-list 105 deny udp any eq netbios-ns any
access-list 105 deny udp any eq netbios-dgm any
access-list 105 permit ip any any


View the Bandwidth


From the enable command prompt:



Router#wr term



Within the config, you will see an interface serial 0 section:



interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

Add a Static Route

From the enable command prompt:



Cisco#config t
Enter configuration commands, one per line. End with CNTL/Z.
Cisco(config)#ip route DEST.DEST.DEST.DEST MASK.MASK.MASK.MASK GATE.GATE.GATE.GATE
where: DEST.DEST.DEST.DEST = The destination network the static route is for
MASK.MASK.MASK.MASK = The subnet mask of the destination network
GATE.GATE.GATE.GATE = The gateway of the static route
Example route statement:
ip route 38.222.75.0 255.255.255.0 38.20.5.1
Cisco(config)#^Z (hit z)



Write the entry to memory:



Cisco#wr mem
Building configuration...
[OK]

Change the Dial Number

At the prompt:



Type en to put the router in enable mode:



test.com>en



The password should be the same as the one used to telnet in.



Password:



To view the router's configuration, type:



test.com#show config



There will be a line in the configuration that says:



dialer map IP 38.1.1.1 speed 64 name LD3330 2707000



The 2707000 is the dial number.








NOTE: Record what interface the dialer map IP line is under
because you will need to use that interface when changing the number.





Type config t to configure from terminal.



test.com#config t



Enter configuration commands, one per line. End with CNTL/Z.
Enter the interface that the dialer map IP line is under:



test.com(config)#interface BRI0



Add in the new dialer map IP line with the new phone number:



test.com(config)#dialer map IP 38.1.1.1 speed 64 name LD3330 [new number]



Now, remove the old dialer map IP line.
To remove a line, type no and then the line.
For example, to remove the old dialer map IP, type:



test.com(config)#no dialer map IP 38.1.1.1 speed 64 name LD3330 2707020



Now leave config mode:



test.com(config)# [control] z



Save changes:



test.com# write mem
Building configuration...
[OK]



Verify the new number is in the config:



test.com#show config



The new number should be in the dialer map IP line.

Turn Filters On and Off


From the enable command prompt:



To turn the filters off:



Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#no ip access-group 104 in
Router(config-if)#no ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#



To turn the filters on:



Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#ip access-group 104 in
Router(config-if)#ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#

Ping from the Router

From the enable command prompt, type:



Cisco#ping
Example:
Cisco#ping 38.8.14.2

Tuesday, September 25, 2007

Switch or Router?

By: Ionut Ilascu, Editor, Software Reviews
news.softpedia.com


Browsing the network forums on the Internet I came across lots of stupid questions and even more stupid answers. At one point a "networkly retarded" guy (these are his own words) was asking for some help for choosing between a hub, a switch or a router in order to connect the two computers he had to the Internet without too much fuss. One of the answers was extremely funny and misleading. The "good samaritan" there guided our net-tard towards buying a hub as it offered great protection and the computers will connect to the Internet with no problems.

The poor guy went to the IT depot and bought a hub (he must have searched a lot for one) and after trying it he came back to the forum saying it did not work and that the computers were communicating perfectly between each other but
there was no WAN available. Another samaritan gave him the idea of buying a network switch, as it would definitely solve the problem. The net-tard went back to the IT shop and got himself a network switch. Obviously it did not work either so he bought a router. Problem solved.

Why all this hassle? Because he did not snoop around the Internet for appropriate advice and because it was more comfortable to be handed the solution then read about the properties of network hubs, switches and routers.



The hubs and switches are great for creating a LAN (well, switches, as hubs are extinct in my opinion). The connection between the computers is stable and the transfer rates are high (the dual-speed hubs supported speeds of even 100Mb). The trouble with the hubs is that you cannot connect two computers to the Internet with it. You will also need another network adapter installed on one of the computers in order to get the Internet connection from the modem. This way, the computer with the Internet connection will function as a gateway for the other one and share the WAN connection.



The same happens with network switches. They also need a gateway for Internet connection sharing. The difference is that while hubs operate using a broadcast model (in a larger network, when two computers communicate with each other, the hub will pass through all the traffic of the network), switches can determine the individual traffic and send the data only to the computer that needs it. This is because of the virtual circuit model used. To put it simpler, switches do not have a big mouth and keep the "conversation" between the computers involved.

In the case of the switches, the data packets are inspected the minute they are received in order to detect the source and destination. After the sender and receiver have been established, the switch will forward the packets accordingly.

Routers represent the smartest way of connecting an entire LAN to the Internet. You need no supplementary network cards (it is a layer 3 gateway itself) and it is highly configurable for protecting your LAN.



Nowadays, routers provide DHCP and proxy support. More than this, the routers offer integrated firewalls for protecting your LAN. A huge step in networking has been made with routers. This is the most convenient device to connect the home network to the Internet without much hassle. All you need is some minimum information from your ISP (global IP address, DNS, gateway address) and you are done.

And as most ISPs have DHCP servers, all this data will be appended to your router automatically without you making any modification.

The features incorporated in the router include creating DMZs (demilitarized zones – a network between LAN and WAN) which is a great way of protecting the data in the SOHO network. Illegal access to your network stops in the DMZ and there will be no damage.

As switches and routers have very close prices, in SOHO networks it is simpler to have the computers directly connected to a router. With the expansion of Wi-Fi technology and the incorporated access points in the routers, things are getting less and less complicated and setting up a home network has become a trivial task.

The bottom line is that the aforementioned user in distress should have looked better before buying first the hub (I can't imagine where he could find one), then the switch, to ultimately find the appropriate device he needed, the router.

For a two computer LAN, a router will do just fine and you won't get a headache configuring it. As for wireless networking support of routers, I stand by my opinion and choose the wired alternative for its stability and inexpensiveness.

Apple to Kill 17-Inch iMac in Next Update? - -

--The fabled 'Mac' would be perfect to fill the resulting hole...

By: Victor Mihailescu, Apple News Editor
news.softpedia.com

Rumors about the next generation of iMacs have resurfaced, and after several months still sing the same song. It looks like the smallest member of the iMac family will be left behind for good.

Rumors that the next generation of iMacs will have a new redesigned look, but will drop the 17-inch model started surfacing in March. After almost three years since the current design debuted, a change of looks would not go amiss. However, the decision to exclude
the smallest iMac from the update, and even potentially kill it off altogether came as a surprise. While it is quite possible for Apple to refresh the iMac line and come out with a 20i-inch model around the same price as the previous 17-inch model, many prefer the smaller sized desktop.

Dropping the 17-inch iMac altogether would leave rather a large hole in Apple’s lineup. For one thing, there is the educational market, where the mini is often not enough, but a 20-inch iMac would be too much. Apple needs a cheaper, entry-level model, and the mini – while great at what it does – is considered by many as a bad choice due to the fact that it is both dated and lacking a display and peripherals.

Dropping the 17-inch iMac and offering the 20-inch model for around the same price could be done, but that would mean having to upgrade the mini because the gap between the two would simply be far too large. Conversely, Apple could do something totally unexpected and drop a bomb by introducing a new model that would be somewhere between the mini and the Mac Pros, without a display, and priced around what the former 17-inch iMac used to cost. This fabled ‘Mac’ has long been awaited by loyal Apple customers and potential switchers alike, and would go a long way to improving Apple’s computer line-up.

Monday, September 24, 2007

The XP alternative for Vista PCs

By Ina Fried, News.com
Published on ZDNet News


While Microsoft is still pushing Vista hard, the company is quietly allowing PC makers to offer a "downgrade" option to buyers that get machines with the new operating system but want to switch to Windows XP.

The program applies only to Windows Vista Business and Ultimate versions, and it is up to PC makers to decide how, if at all, they want to make XP available. Fujitsu has been among the most aggressive, starting last month to include an XP disc in the box with its laptops and tablets.

"That's going to help out small- and medium-size businesses," Fujitsu marketing manager Brandon Farris told CNET News.com.

Hewlett-Packard also started a program in August for many of its business models. "For business desktops, workstations and select business notebooks and tablet PCs, customers can configure their systems to include the XP Pro restore disc for little or no charge," HP spokeswoman Tiffany Smith said in an e-mail. She said it was too soon to gauge how high customer interest has been. "Since we've only been offering (it) for about a month, we don't really have anything to share on demand."



A Microsoft representative confirmed there were changes made over the summer to make it easier for customers to downgrade to XP. Under Microsoft's licensing terms for Vista, buyers of Vista Business and Vista Ultimate Edition have always had the right to downgrade to XP, but in practice this could be challenging. In June, Microsoft changed its practices to allow computer makers that sell pre-activated Vista machines to order Windows XP discs that could be included inside the box with PCs, or shipped to customers without requiring additional activation. Microsoft noted in a statement that neither it nor the PC makers are "obligated to supply earlier versions to end users under the end user licensing terms."

While there is always resistance by some to move to a new operating system, there appears to be particularly strong demand, especially from businesses, to stick with XP.

One of the challenges, for both businesses and consumers are Vista's hefty graphics and memory needs.

Lenovo, for its part, has details for its downgrade program on its IBM ThinkPad Web site.

Dell spokeswoman Anne Camden said Dell has been offering businesses that have a Premier Page set up the option to order systems with XP, Vista or Vista with XP downgrade rights. There is no extra charge for the downgrade rights.

"We've been offering it and we're still offering it," she said.

HP, Gateway and others also still sell machines with XP on them, nearly a year after Microsoft first started offering Vista to businesses. Vista went on sale broadly to consumers in January, at which point XP largely disappeared from retail shelves.

However, demand for XP has remained. In April, Dell brought XP back as an option even on consumer PCs.

There is an issue, though, over how long PC makers can keep selling machines with Windows XP as the preloaded operating system. Microsoft is requiring large PC makers to stop selling XP-based systems as of January 31, though some PC makers would like to sell XP machines for longer.

"We're all lobbying for it," Farris said.

Google seeks EU approval to buy DoubleClick

Google filed with the European Union competition regulator on Friday for permission to buy rival DoubleClick for $3.1 billion, and the deal almost immediately became contentious.

The European Commission said it had set a review deadline of October 26, when it could approve the deal, give a two-week extension or open an in-depth, four-month investigation.

"We are asking the European Commission to look at the proposed acquisition. We believe this deal is positive for both users and advertisers, and fosters competition," Julia Holtz, Google's competition counsel, told Reuters.

But rival Yahoo immediately issued its own statement over the deal, seeking an in-depth review.

"The deal raises important questions about the future of Internet advertising. These questions warrant an in-depth debate and review by a broad range of Internet publishers, advertisers, service providers, and governments in Europe and elsewhere," said Toby Coppel, managing director of Yahoo Europe.

Others, including Microsoft and AT&T, have asked U.S. antitrust officials to look closely at the proposed takeover, saying Google could gain too much control over online advertising.

The Commission has already sent questionnaires asking competitors and customers what they think about the deal.

DoubleClick is in the business of online advertising, as is Web search provider Google. DoubleClick connects ad agencies, marketers and Web site publishers, and has more than 1,500 corporate clients.

Google has already filed with the U.S. Federal Trade Commission and with the Australian competition regulator.

Story Copyright © 2007 Reuters Limited. All rights reserved.
http://www.reuters.com/

Sunday, September 23, 2007

From the vastness of the Internet!

ON METAPHYSICS
Deja Fu: The feeling that somehow, somewhere, you've been kicked in the head like this before.

ON DEEP THOUGHTS
A day without sunshine is like night.

ON PARADOX AND RETURN POLICIES
There is a CD out entitled "The Worst of Jefferson Airplane". If you buy this, take it home, play it, and enjoy it, should you take it back and demand a refund?

ON HIGHER EDUCATION
College is a fountain of knowledge... and the students are there to drink.

ON MATHEMATICAL TRANSFORMS
A polar bear is a rectangular bear after a coordinate transform.

ON YOUTH
Some people say that I must be a horrible person, but that's not true. I have the heart of a young boy -- in a jar on my desk.
-- Stephen King, 3/8/90

ON PROBLEM SOLVING
When the only tool you own is a hammer, every problem begins to resemble a nail.
-- Abraham Maslow

ON MATERIALISM
He who dies with the most toys, is, nonetheless, still dead.

ON RELIGIOUS PRACTICES
Photons have mass? I didn't know they were Catholic!

ON INFINITY
If you had everything, where would you keep it?

ON ECONOMICS
The cost of living hasn't affected its popularity.

ON PUBLISHING OR PERISHING
I am returning this otherwise good typing paper to you because someone has printed gibberish all over it and put your name at the top.
-- English Professor, Ohio University

ON REVISIONIST HISTORY
What was sliced bread the greatest thing since?

ON DATING
When aiming for the common denominator, be prepared for the occasional division by zero.

ON POETIC LOVE
When you're swimmin' in the creek
And an eel bites your cheek
That's a moray!
-- Fabulous Furry Freak Brothers

ON MODERNISM
Q: How many surrealists does it take to screw in a light bulb?
A: Two. One to hold the giraffe and the other to fill the bathtub with brightly colored machine tools.

ON MATERIAL SCIENCE
Character density: The number of very weird people in the office.

ON EXTINCTION
Save the whales. Collect the whole set.

ON LITERATURE
This is not a novel to be tossed aside lightly. It should be thrown with great force.
-- Dorothy Parker

ON HUMILITY
To err is human, to moo bovine.

ON EXPLANATION OF THE END ...
One of the main causes of the fall of the Roman Empire was that, lacking zero, they had no way to indicate successful termination of their C programs.
-- Robert Firth

ON PROPHECY
The meek shall inherit the earth -- they are too weak to refuse.

ON EXCUSES
I can't complain, but sometimes I still do. -- Joe Walsh

ON NUMBERS
Grabel's Law: 2 is not equal to 3 -- not even for very large values of 2.

ON WORLD POLITICS
Diplomacy is the art of saying "nice doggy" until you can find a rock.

AND FINALLY, ON DRUGS AND DEVELOPMENT
There are two major products to come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence...

Saturday, September 22, 2007

Building a GSM Alarm




Update:
Arduino version coming soon.(will drastically reduce the total cost)


Material Used:
1 - BasicX24
1 - Lynxmotion Mini-ABB as carrier board for the BX24
1 - PIR Sensor Pyronix KX15ED
1 - Old 5V Samsung Cellphone Charger
1 - 9V Power Supply
2 - 9V batteries
1 - Siemens C35


AT Commands & BX24<->Cellphone Communication:
- You may have heard AT commands when talking about old dial-up modems, since these set of commands were used to control the modem and its connections, in case of serial modems these commands were sent over a serial port.
- The thing that some of you dont know is that today cellphones support and use a set of commands called (AT Commands) that are very alike to their old brothers, you can access them via bluetooth if you phone has a serial protocol service or dial-up service over bluetooth or by cable using a simple hyperterminal like tool.
- In this case i connected 2 ports of a BasicX24 directly to the phones RX-TX, well not directly since BasicX24 is TTL (5V) and the RX-TX pins in the cellphone work better at 3V, i say better because with 5V i were able to communicate with the cellphone but when the connection was made the phone lost all the network signal so with 5V you can only access phone functions memory etc, no sms neither calls. Im not sure if this happens in all the phones but in this case (Siemens C35) it happened, to resolve this problem, a interface was built to downgrade the voltage from 5V to 3V, i used a voltage divider with a 12K and a 18K resistors.

- "Comparison chart of AT+C commands of GSM devices"
- "Siemens Lumberg cell phone special connector Pinout"
- "Siemens AT Commands"

BasicX24:
- In order to comunicate with the cellphone like i said before, 2 ports were used, these ports were configured to function like RX TX of COM3.
- Another port was used as input to the PIR sensor, that is gona be used to detect movement like those cheap light sensors.

To be Implemented in near future:
- Since this cellphone has 2 pins to use with an external microphone, im thinking on using this to amplify the cellphone microphone in order to be able to listen what is happening in the remote place.


How it Works:
Power:- There is a 9v power supply connected to a pair of 9V batteries, these bats are connected in parallel and are powering the BX24 and PIR sensor. The other power supply is an old 5V Samsung cellphone charger that was dismanteled, i use this one to keep the siemens C35 charged, so if the power goes down i have 400mah(200+200) storaged in batteries for the Microcontroller and PIR Sensor and the cellphone battery for its own, this should be enough to keep the alarm online for a few hours.

Software Logic:



Notes:
- It is really easy to change the alarm mode, for example if you wanted the alarm to call you instead of using sms just change the at command that is sent when the PIR sensor triggers.
- The sms that is sent is an sms storaged in the cellphone memory this way i dont need to send the sms PDU thru the wires, i just order the phone to send that sms to the specified cellphone number :)
- Alot more sensors can be added since we are only using 3 ports of the BX24 and can group them in zones whatever, like all my other work it can be upgraded in something alot more bigger, this is just a good starting point.

Downloads:

Download - BasicX24 Code

:P

Download - Photo1
Download - Photo2
Download - Photo3



Special thanks to: http://alumni.ipt.pt/~pmad/
Pedro Miguel aKa Ap0cN3t 2007
Mail: ap0cn3t@gmail.com